Cédric Luthi ▶️ @0xced@hachyderm.io (@0xced) header
Cédric Luthi ▶️ @0xced@hachyderm.io (@0xced) profile picture

Trying to make people not hate computers by crafting quality software.

Fribourg, Switzerland
Joined April 2008
Photo by Cédric Luthi ▶️ @0xced@hachyderm.io (@0xced)Photo by Cédric Luthi ▶️ @0xced@hachyderm.io (@0xced)Photo by Cédric Luthi ▶️ @0xced@hachyderm.io (@0xced)Photo by Cédric Luthi ▶️ @0xced@hachyderm.io (@0xced)Photo by Cédric Luthi ▶️ @0xced@hachyderm.io (@0xced)Photo by Cédric Luthi ▶️ @0xced@hachyderm.io (@0xced)Photo by Cédric Luthi ▶️ @0xced@hachyderm.io (@0xced)Photo by Cédric Luthi ▶️ @0xced@hachyderm.io (@0xced)Photo by Cédric Luthi ▶️ @0xced@hachyderm.io (@0xced)Photo by Cédric Luthi ▶️ @0xced@hachyderm.io (@0xced)
“No ads. We build products that we want for ourselves, too, and we just don't want ads.”
Now my app’s product page shows gambling ads, which I’m really not OK with. Apple shouldn’t be OK with it, either. The App Store has corrupted such a great company so deeply. They make so much from gambling and manipulative IAPs that they don’t even see the problem anymore.
17
130
20
811
The countless times Apple took down a scam I exposed, only to leave up all of the developer’s other scam apps… Why do we trust *Apple* to run an iOS App Store? We don’t. We just have no choice. Let *users* vote with their trust, not gatekeepers.
Replying to @TimSweeneyEpic
Microsoft would be great. But why would Apple trust Epic with a ham sandwich at this point, let alone running an App Store? Who trusts a rule breaker not to break the rules again?
1
7
39
New blog post is live! In which I download 4 TB of Python packages containing native x86-64 libraries and see how many of them use -ffast-math, potentially altering floating point behavior in any program unlucky enough to load them! moyix.blogspot.com/2022/09/s…
27
218
81
971
Someone asked me if I could detail our third-party library process at Lyft, so I wrote about it: scottberrevoets.com/2022/07/… (Also if there are other topics you want to hear about feel free to ask!)
1
11
1
39
How did REST come to mean the opposite of REST? htmx.org/essays/how-did-rest…
6
22
7
87
today i published a video about ⁦@Humane⁩ a company that has been operating in stealth since 2017 has $130M in funding (no products + no announcements) and has hired 140 employees (60 of which came from apple) here’s everything we know so far: youtu.be/hlJxWpsuChk
13
20
4
160
Web3 is here!
Today, after over 5 years of work, HTTP/3 was finally standardized as RFC 9114! rfc-editor.org/rfc/rfc9114.h… Together with RFC 9204 (QPACK header compression) and RFC 9218 (Extensible Priorities) it ushers in an important new chapter for the Web! Proud to have been part of this!
22
84
10
618
Cédric Luthi ▶️ @[email protected] retweeted
Steve Jobs was great at product announcements. The iPhone introduction was fantastic showmanship. Unfortunately, his example has been a bad longterm influence. The goal should be to make a great products, not to make a big splash on stage at a conference.
14
17
4
329
Replying to @MarusykRoman
Note that this is how the early preview worked. After preview feedback we've changed the feature to require the utf8 literals have the u8 suffix on them. ReadOnlySpan<byte> span = "hello world"u8;
6
4
2
41
New blog post about the enhancements for the Mach-O format: codesign, bin2lib, code injection and more :) 🔗 lief-project.github.io/blog/…
38
1
133
Cédric Luthi ▶️ @[email protected] retweeted
Do you prefer the old style macOS alerts? There is a way to get them globally for AppKit in Big Sur and Monterey: defaults write -g NSAlertMetricsGatheringEnabled -bool false
15
56
13
242
turns out all browsers render gifs wrong and now the wrong behavior is expected elsewhere too lmao biphelps.com/blog/The-Fastes…
3
19
90
📦 Released Gress v2! If you are working with IProgress<T> in .NET, you might want to check it out. This library provides a set of utilities for collecting, transforming, filtering, and muxing progress in your code. [🟩🟩🟩⬛️⬛️] github.com/Tyrrrz/Gress #dotnet #csharp #fsharp
1
11
54
A trillion dollar company.
Replying to @spotmac
Thanks for contacting us. To get help with this issue, please reach out to Curl: curl.se/gethelp.html
31
495
38
2,365
Free Apple support. daniel.haxx.se/blog/2021/11/… - we're here to help the struggling companies.
12
153
13
398
I like the idea of preserving games (and apps and websites), but I am afraid we are now looking at millions of these rendered useless by requiring the backend services to be operating. The golden era of the self-contained app are gone.
Phil Spencer calls for industry-wide support of emulation for older games to preserve the past “If we said, ‘Hey, anybody should be able to buy any game, or own any game and continue to play,' that seems like a great North Star for us as an industry.” axios.com/microsoft-old-game…
15
11
2
138
Thanks for your replies! I put the results in a post: kean.blog/post/learn-ios
I need your help, Twitter. What are the best learning resources for beginner/intermediate iOS engineers these days (can be paid)?
8
29